Project

General

Profile

Actions

Demande #6450

open

Rendre formatsouverts compatible avec PHP 8.x

Added by Romain H. about 1 month ago.

Status:
Nouveau
Priority:
Normale
Assignee:
-
Category:
-
Target version:
Start date:
06/02/2024
Due date:
% Done:

0%

Estimated time:
Difficulté:
3 Moyen

Description

Le site https://formatsouverts.education est une instance de gspeakup qui utilise Smarty 2.x.

Smarty 2.x ne supporte pas la version de php de Debian stable (php8.2).
Il faudrait mettre à jour gspeakup pour passer sur Smarty 5.x qui supporte cette version de php.

J'ai testé de faire la migration rapidement sur lamp mais sans succès car cella demande un peu de travail, notamment parce que les blocks {php} qui permettait d'inclure du code PHP directement dans les templates n'existent plus.

No data to display

Actions

Also available in: Atom PDF