Project

General

Profile

Anomalie #6100

Problème « kernel panic » au démarrage du laptop absinthe suite à installation d'un nouveau noyau

Added by Frédéric Couchet 12 months ago. Updated 12 months ago.

Status:
Fermé
Priority:
Normale
Category:
-
Target version:
Start date:
02/27/2023
Due date:
% Done:

0%

Estimated time:
Difficulté:
2 Facile

Description

Suite à une mise à jour du laptop absinthe, et installation d'un nouveau noyau Linux (le 6.1.0-3) quand j'ai redémarré il y a eu un kernal panic, unable to mount root fs juste après le démarrage du noyau.

History

#1

Updated by Frédéric Couchet 12 months ago

En fait, la mise à jour se terminait pas une erreur :

cd src/ && make KVERSION=6.1.0-3-amd64 BUILD_KERNEL=6.1.0-3-amd64...(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-3-amd64 (x86_64)
Consult /var/lib/dkms/e1000e/3.8.7/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 11
dpkg: erreur de traitement du paquet linux-image-6.1.0-3-amd64 (--configure) :
 le sous-processus paquet linux-image-6.1.0-3-amd64 script post-installation installé a renvoyé un état de sortie d'erreur 1
Paramétrage de mariadb-server-core (1:10.11.2-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de linux-headers-amd64 :
 linux-headers-amd64 dépend de linux-headers-6.1.0-3-amd64 (= 6.1.8-1); cependant :
 Le paquet linux-headers-6.1.0-3-amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-headers-amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de default-mysql-server-core (1.1.0) ...
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-amd64 :
 linux-image-amd64 dépend de linux-image-6.1.0-3-amd64 (= 6.1.8-1); cependant :
 Le paquet linux-image-6.1.0-3-amd64 n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-image-amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de default-mysql-client-core (1.1.0) ...
Traitement des actions différées (« triggers ») pour man-db (2.11.2-1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 linux-headers-6.1.0-3-amd64
 linux-image-6.1.0-3-amd64
 linux-headers-amd64
 linux-image-amd64
======  How can you help?  (doc: https://wiki.debian.org/how-can-i-help ) ======

-----  Show old opportunities as well as new ones: how-can-i-help --old  -----
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
#2

Updated by Frédéric Couchet 12 months ago

Olasd m'a signalé que e1000e est built-in dans le noyau, donc pas besoin d'avoir e1000e en dkms. Visiblement j'avais installé ça suite à un problème de carte réseau sur mon laptop en 2021.

J'ai supprimé le module e1000e-dkms et relancé l'upgrade qui s'est terminée correctement.

#3

Updated by Frédéric Couchet 12 months ago

  • Status changed from Nouveau to Résolu

Reboot ok.

#4

Updated by Frédéric Couchet 12 months ago

  • Status changed from Résolu to Fermé
  • Target version changed from Backlog to Février 2023
#5

Updated by Frédéric Couchet 12 months ago

  • Target version changed from Février 2023 to Mars 2023
#6

Updated by Quentin Gibeaux 12 months ago

  • Target version changed from Mars 2023 to Février 2023

Also available in: Atom PDF