Project

General

Profile

Demande #5224

La prochaine mise à jour Dotclear www.candidats.fr et www.freesoftwarepact.eu nécessite PHP 7

Added by Christian P. Momon 11 months ago. Updated 20 days ago.

Status:
Nouveau
Priority:
Élevée
Category:
-
Target version:
Start date:
02/17/2021
Due date:
% Done:

0%

Estimated time:
Difficulté:
6 Très difficile

Description

Lors de la mise à jour 2.18.1, un message est apparu :

Les prochaines versions de Dotclear ne supporteront par les versions de PHP < 7.0, la votre est actuellement la 5.6.40-0+deb8u7

Demande : étudier une solution d'ici la prochaine mise à jour.

Solutions envisageables :
  • activer PHP7 sur l'Apache de la vm candidatsfr (mais il faut au préalable évaluer la compatibilité des applications April sur la même vm) ;
  • archiver le site www.freesoftwarepact.eu ;
  • activer le module php_fpm ;
  • migrer les dotclears vers la vm lamp (comme pour le Dotclear de proximité) ;
  • autre…

Related issues

Related to Admins - Demande #5220: Mettre à jour Dotclear CandidatsFR en 2.18.1Fermé04/17/2020

Actions
Related to Admins - Demande #5218: Mettre à jour Dotclear www.freesoftwarepact.eu en 2.18.1Fermé03/30/2020

Actions
Related to Admins - Anomalie #4016: Les sites PHP de la vm candidatsfr tourent encore en php5Attente d'information11/15/201907/01/2022

Actions
Related to Admins - Demande #5539: Mettre à jour Dotclear CandidatsFR en 2.19Nouveau04/17/2020

Actions
Related to Admins - Demande #5538: Mettre à jour Dotclear proximite.april.fr en 2.19Fermé

Actions
Related to Admins - Demande #5537: Mettre à jour Dotclear www.freesoftwarepact.eu en 2.19Nouveau

Actions
Related to Admins - Demande #5659: Avenir de candidats.frFermé11/20/2021

Actions

History

#1

Updated by Christian P. Momon 11 months ago

  • Subject changed from La prochaine mise à jour Dotclear www.freesoftwarepact.eu nécessite PHP 7 to La prochaine mise à jour Dotclear www.candidats.fr et www.freesoftwarepact.eu nécessite PHP 7
  • Description updated (diff)
#2

Updated by Christian P. Momon 11 months ago

  • Related to Demande #5220: Mettre à jour Dotclear CandidatsFR en 2.18.1 added
#3

Updated by Christian P. Momon 11 months ago

  • Related to Demande #5218: Mettre à jour Dotclear www.freesoftwarepact.eu en 2.18.1 added
#4

Updated by Quentin Gibeaux 11 months ago

  • Assignee set to Edouard Dausque
#5

Updated by Quentin Gibeaux 11 months ago

  • Target version changed from Février 2021 to Mars 2021
#6

Updated by Christian P. Momon 11 months ago

  • Related to Anomalie #4016: Les sites PHP de la vm candidatsfr tourent encore en php5 added
#7

Updated by Quentin Gibeaux 10 months ago

  • Target version changed from Mars 2021 to Avril 2021
#8

Updated by Quentin Gibeaux 9 months ago

  • Target version changed from Avril 2021 to Mai 2021
#9

Updated by Quentin Gibeaux 8 months ago

  • Target version changed from Mai 2021 to Backlog
#10

Updated by Christian P. Momon 5 months ago

  • Priority changed from Normale to Élevée

La version 2.19 est sortie et confirme le prérequis de PHP 7.3 : https://fr.dotclear.org/blog/post/2021/08/13/Dotclear-2.19

Au programme un code (PHP et Javascript) plus robuste, quelques améliorations pour les développeurs de thèmes,
une version minimale de PHP 7.3 requise, la compatibilité avec PHP 8 étant assurée, les quelques bibliothèques
utilisées ont été mises à jour (jQuery, CKEditor, codemirror, …).

#11

Updated by Christian P. Momon 5 months ago

  • Related to Demande #5539: Mettre à jour Dotclear CandidatsFR en 2.19 added
#12

Updated by Christian P. Momon 5 months ago

  • Related to Demande #5538: Mettre à jour Dotclear proximite.april.fr en 2.19 added
#13

Updated by Christian P. Momon 5 months ago

  • Related to Demande #5537: Mettre à jour Dotclear www.freesoftwarepact.eu en 2.19 added
#14

Updated by François Poulain about 2 months ago

#15

Updated by Frédéric Couchet about 2 months ago

  • Assignee changed from Edouard Dausque to Benjamin Drieu
  • Target version changed from Backlog to Décembre 2021
#16

Updated by Quentin Gibeaux 20 days ago

  • Target version changed from Décembre 2021 to Janvier 2022

Also available in: Atom PDF