Project

General

Profile

Demande #4707

youtube-dl en retard dans le paquet debian

Added by Quentin Gibeaux about 2 months ago. Updated about 2 months ago.

Status:
Fermé
Priority:
Normale
Assignee:
-
Category:
-
Target version:
Start date:
09/01/2020
Due date:
% Done:

0%

Estimated time:
Difficulté:
2 Facile

Description

Remonté par Etienne, youtube-dl ne fonctionne pas de manière idéale pour récupérer les fichiers.
La version packagée de debian buster date de janvier 2019, la version sur le site web date de juillet 2020.
Est-ce qu'on bascule ?
Ce paquet installe un jeu de script pour récupérer des vidéos sur le web, c'est un jeu de chat et de la souris avec des réfections régulières pour suivre les verrous mis en place au fur et à mesure.

Un autre solution serait d'installer la version testing qui est récente, ou la version sid, en dpkg -i, si ça ne pose pas de problème de dépendance.

History

#1

Updated by Quentin Gibeaux about 2 months ago

testé la version bullseye, elle s'installe en buster sans problème de dépendance.
(wget + dpkg -i)

#2

Updated by Quentin Gibeaux about 2 months ago

wget http://ftp.us.debian.org/debian/pool/main/y/youtube-dl/youtube-dl_2020.07.28-1_all.deb
sudo dpkg -i youtube-dl_2020.07.28-1_all.deb
#3

Updated by Christian P. Momon about 2 months ago

  • Status changed from Nouveau to En cours de traitement
- buster :           2019.01.17-1.1
- buster-backports : 2020.06.16.1-1
- bulleyes :         2020.07.28-1
- dernière version : 2020.07.28
Deux solutions :
1) version du projet officiel
  • Avant il semble qu'Étienne faisait youtube-dl -U pour mettre à jour donc ça indiquerait que c'était la version venant directement du projet ;
  • si c'était la version du projet officiel sur sa précédente machine, pourquoi ne pas continuer ?
  • réactivité et autonomie assurée
2) version bulleyes :
  • faibles dépendances du paquets se résumant à python3 : https://packages.debian.org/bullseye/youtube-dl ;
  • avec un apt/source.list.d bien configuré, ça le ferait bien ;
  • confiance Debian ;
  • rend Étienne dépendant des mises à jour de sa machine ;
  • est-ce que le paquet bulleyes est rapidement mis à jour ?
#4

Updated by Quentin Gibeaux about 2 months ago

Etienne a installé la version bulseye sur mon conseil, donc pour l'instant c'est bon.

le -U ne marche plus, désactivé par le paquet Debian.

Le soucis de passer par le -U (mais peut être acceptable) est qu'il revient à exécuter en root du code venant d'un site web hors périmètre Debian, ça pose un problème de confiance, le sujet ne réside que sur ce questionnement.

#5

Updated by Christian P. Momon about 2 months ago

Pas nécessairement en root. On peut utiliser l'exécutable du projet officiel directement sous son propre compte, et les youtube-dl -U fonctionnent aussi.

Cela ne change au rien à ta remarque très pertinente sur la confiance.

Du coup, ça vaut vraiment le coup de tenter avec le paquet Debian bulleyes <3

Suggestions :
  • paramétrer le source.list.d pour les mises à jour :D
  • le généraliser à la conf machine permanents ?
#6

Updated by Quentin Gibeaux about 2 months ago

  • Status changed from En cours de traitement to Fermé

Also available in: Atom PDF