Project

General

Profile

Anomalie #3814

pad.april.org : deux versions différentes de npm cohabitent

Added by Christian P. Momon about 1 month ago.

Status:
Nouveau
Priority:
Normale
Assignee:
-
Category:
-
Target version:
Start date:
07/14/2019
Due date:
% Done:

0%

Difficulté:
2 Facile

Description

Actuellement :

(April) root@pad:/srv/etherpad-lite[live-1.7.0$%]# which npm
/usr/bin/npm
(April) root@pad:/srv/etherpad-lite[live-1.7.0$%]# dpkg -S /usr/bin/npm
nodejs: /usr/bin/npm
(April) root@pad:/srv/etherpad-lite[live-1.7.0$%]# dpkg -l nodejs
Desired=Unknown/Install/Remove/Purge/Hold
ii  nodejs                                                6.13.0-1nodesource1             amd64                           Node.js event-based server-side javascript engine
(April) root@pad:/srv/etherpad-lite[live-1.7.0$%]# npm -v
3.10.10
(April) root@pad:/srv/etherpad-lite[live-1.7.0$%]# /srv/etherpad-lite/src/node_modules/.bin/npm -v
6.4.0

Clairement la version 3.10.10 est obsolète et confusante pour l'opérateur.

Questions :
  • pourquoi la version par défaut est si ancienne ?
  • est-ce lié à la nom mise à jour de NodeJS (voir #3809) ?
  • possibilité de mettre à jour ?

Also available in: Atom PDF