Project

General

Profile

Demande #3693

Firefox considère toutes les extensions comme obsolètes

Added by Christian P. Momon 4 months ago. Updated 4 months ago.

Status:
Attente d'information
Priority:
Normale
Assignee:
-
Category:
-
Target version:
Start date:
05/05/2019
Due date:
% Done:

0%

Difficulté:
2 Facile

Description

Soudainement, sans même le relancer, Firefox considère toutes les extensions comme obsolètes et les désactive. Même les extensions correctes.

History

#1 Updated by Christian P. Momon 4 months ago

  • Status changed from Nouveau to Attente d'information

C'est un bug côté Mozilla : https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

Late on Friday May 3rd, we became aware of an issue with Firefox that prevented existing and new add-ons from running or being installed. We are very sorry for the inconvenience caused to people who use Firefox.

#2 Updated by Christian P. Momon 4 months ago

Une solution de contournement pour les Firefox buildés par Mozilla :

#3 Updated by Christian P. Momon 4 months ago

Solution de contournement « non officielle » donnée dans un des commentaires de la page https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

Samuel Vuorela wrote on May 4, 2019 at 9:20 am: 
Why not just post a link to the fix that can be installed WITHOUT enabling Studies? This sounds like a clever plan to get more people to share their data via Studies…
The fix in question can be installed by clicking this link [1]. It’s signed by Mozilla.
Thanks to user gpm at Hacker News, who posted this tip [2].
[1] https://storage.googleapis.com/moz-fx-normandy-prod-addons/extensions/hotfix-update-xpi-intermediate%40mozilla.com-1.0.2-signed.xpi
[2] https://news.ycombinator.com/item?id=19826903

#4 Updated by Christian P. Momon 4 months ago

Solution de contournement pour le build Debian Buster :

Sur IRC#april-admin :
11:48 < madix> passage furtif, concernant firefox version 60.6.1esr sur Buster une solution est : aller dans about:config
et changer xpinstall.signatures.required de true à false, et les extensions sont de retour
11:49 < madix> pas testé sur debian stable

#5 Updated by Christian P. Momon 4 months ago

Résolu pour les Firefox buildés par Mozilla :

A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR.

Je confirme que ça fonctionne.

Also available in: Atom PDF